Intermittent email delivery issues
Incident Report for Ironclad Clickwrap
Postmortem

What happened?

On February 9, 2017 at approximately 4:20pm EST we discovered that our release on February 2nd introduced an issue when adding new Signers to a Signature Request. That issue caused new Signers to not be sent emails from PactSafe when a Signature Request was sent.

What was affected?

New Requests created after our February 2nd release where new Signers were added likely did not receive email notifications that they had Contracts to sign.

Why did it happen?

This issue happened because of the recent addition of support for SMS sending and accepting of Contracts. We added a permission in limited release that would allow you to enable or disable both email and SMS for folks you send contracts to. When SMS was not enabled in your account (almost all of our customers), there was a bug in how email sending was enabled/disabled and therefore caused emails not to send.

What are we doing to prevent this from happening again?

Backwards compatibility and regular releases and delivery of product is something we hold very near and dear to what makes PactSafe one of the leading innovators in the space. That being said, we absolutely cannot introduce new features without first ensuring every single part of the solution that you trust is working flawlessly and as expected.

We've added 3 additional steps for pre-release testing that will ensure we catch important pieces in the contract sending flow in the future. We're proud of the steps and process we've put in place to harden our release process and ensure the product we're releasing is great. We are taking the learnings of this issue on board to prevent it from happening again.

Posted Feb 09, 2017 - 17:52 EST

Resolved
We have identified and deployed a fix for the issue. All emails for Requests will—from now on—be sent successfully.
Posted Feb 09, 2017 - 17:24 EST
Investigating
We are currently investigating an issue where some emails sent as part of a Signature Request are not being sent. We have identified what's happening and are researching a fix.
Posted Feb 09, 2017 - 16:36 EST