DNS issue on pactsafe.io
Incident Report for Ironclad Clickwrap
Postmortem

What happened?

The name servers behind the .io top-level domain experienced intermittent issues resolving DNS records for .io domains. These periodic domain resolution failures affected all .io domains globally, including our pactsafe.io domain.

What was affected?

Customers may have encountered periodic domain resolution failures on requests to the PactSafe services hosted at pactsafe.io, vault.pactsafe.io, and all other sub-domains of pactsafe.io. This includes requests to our Activity API, as well as downloads of our published JS library (ps.js) and clickwrap groups.

Since this affected all .io domains globally, we also experienced resolution issues with a handful of third-party services utilized by PactSafe. These services include our in-app live chat, contextual help, and our status page which displays the health of each PactSafe service.

Why did it happen?

It is unclear exactly what caused the resolution issues on the global .io TLD name servers. Unfortunately, these name servers are managed at a DNS level outside of the control of PactSafe or any company utilizing a .io domain. We are exploring alternatives in the future to migrate these APIs to a more established enterprise domain, but haven't committed to a timeframe for migration and will continue to support our existing API infrastructure for the near term.

Posted Sep 21, 2017 - 15:49 EDT

Resolved
This issue was resolved around 11:45am EST and all systems are operational.
Posted Sep 20, 2017 - 13:20 EDT
Monitoring
The DNS seems to have resolved—we are monitoring closely to ensure we're fully back online.
Posted Sep 20, 2017 - 09:35 EDT
Investigating
We are currently investigating a DNS issue that's causing pactsafe.io to return a 404 error. We will post an update on the status of this issue in the next 10-15 minutes.
Posted Sep 20, 2017 - 09:32 EDT