Email sending delay (SendGrid)
Incident Report for PactSafe
Resolved
SendGrid has confirmed that they are now receiving and processing mail normally, which we have also confirmed in our reporting.
Posted Jul 28, 2020 - 14:26 EDT
Monitoring
Emails delivery has resumed and should be functioning normally. A slight delay may still be possible between sending and delivery. We are still actively monitoring to confirm.
Posted Jul 28, 2020 - 13:39 EDT
Investigating
The third party service used to deliver emails on behalf of PactSafe is currently experiencing an outage.
Posted Jul 28, 2020 - 12:48 EDT
This incident affected: Delivery Services (Outbound Email, Inbound Delivery Confirmations) and SendGrid API v3.