Issues with logging into PactSafe
Incident Report for Ironclad Clickwrap
Resolved
An issue with our payments/subscription provider caused our login process to go down temporarily. They are now back online and logins should be back to normal.
Posted Feb 15, 2017 - 11:41 EST
Investigating
We are currently investigating an issue with logging into the PactSafe application at app.pactsafe.com.
Posted Feb 15, 2017 - 11:33 EST