Amazon S3 East having some operational issues
Incident Report for PactSafe
Resolved
We are seeing full functionality of uploads and legal centers back online consistently. We're setting the issue to Resolved for now.
Posted Sep 14, 2017 - 16:00 EDT
Update
From Amazon at 3:38pm EST: "We continue to work towards resolving the increased throttling errors for Amazon S3 requests in the US-EAST-1 Region. We have identified the subsystem responsible for the errors, identified root cause and are now working to resolve the issue."
Posted Sep 14, 2017 - 15:43 EDT
Update
From Amazon at 3:21 EST: "We can confirm that some customers are receiving throttling errors accessing S3. We are currently investigating the root cause."

More here: http://status.aws.amazon.com/
Posted Sep 14, 2017 - 15:28 EDT
Identified
Amazon's Simple Storage Service (S3), which hosts PactSafe's Legal Centers and PDFs is having some operational issues. Not all services are effected or are hard down at this point but there are some errors being generated when trying to load these components.
Posted Sep 14, 2017 - 15:23 EDT