Links to sign contracts resulting in security error
Incident Report for PactSafe
Resolved
Emails have been working for a few hours now. We will be reaching out to customers affected by the issue directly (between 3pm and 5pm EST) to resolve issues with links in emails during this time period.
Posted Aug 24, 2020 - 20:30 EDT
Update
We have currently resolved all links going forward, but we are currently working to fix all links delivered between 3pm and 5pm EST. We'll mark this issue as "Resolved" once that fix is in place.
Posted Aug 24, 2020 - 17:23 EDT
Monitoring
We have currently resolved all links going forward, but we are currently working to fix all links delivered between 3pm and 5pm EST. We'll mark this issue as "Resolved" once that fix is in place.
Posted Aug 24, 2020 - 17:23 EDT
Identified
Emails between 3pm and 5pm EST today have been identified as problematic and raising this security issue when signing due to a change in DNS configuration between our email provider and PactSafe.
Posted Aug 24, 2020 - 17:22 EDT
Investigating
We are currently investigating an issue that's caused link redirects to interrupt the user signing with a security error. This is due to a configuration issue that was recently introduced with our email provider that we did not anticipate. We have resolved the issue for emails going forward, but we're now working to introduce a new function to retroactively redirect links that are currently failing.

There is a workaround: To "Proceed" through the signing process, users will successfully be redirected to sign.
Posted Aug 24, 2020 - 17:19 EDT
This incident affected: Delivery Services (Outbound Email, Custom Email Sending Domains).