Amazon S3 Outage
Incident Report for Ironclad Clickwrap
Resolved
Amazon appears to be coming back online. We've successfully:
- Loaded static groups
- Loaded Legal Centers
- Loaded PDFs inside of Requests and Contracts

We're going to resolve this issue for now as AWS S3 comes back online. If any other issue arises we will update accordingly.
Posted Feb 28, 2017 - 16:10 EST
Update
Update from Amazon at 12:52 PM PST: We are seeing recovery for S3 object retrievals, listing and deletions. We continue to work on recovery for adding new objects to S3 and expect to start seeing improved error rates within the hour.
Posted Feb 28, 2017 - 16:05 EST
Update
Many of our hosted Legal Centers are starting to come back online. Unfortunately, static groups and files (PDFs) still appear to be down. Hopefully, we'll start to see additional files start to come back online.
Posted Feb 28, 2017 - 15:50 EST
Update
NOTE: The following pieces of PactSafe are NOT likely operational at this point:
- Loading static Groups using our JavaScript library may be causing issues, but may be cached in some instances.
- Hosted Legal Centers are cached in some instances, but may not be loading successfully.
- PDFs cannot be uploaded or included in contracts. Contract requests that include PDFs may not properly be loading.
Posted Feb 28, 2017 - 14:48 EST
Update
Amazon has now updated their Service Health Dashboard at http://status.aws.amazon.com:
"Update at 11:35 AM PST: We have now repaired the ability to update the service health dashboard. The service updates are below. We continue to experience high error rates with S3 in US-EAST-1, which is impacting various AWS services. We are working hard at repairing S3, believe we understand root cause, and are working on implementing what we believe will remediate the issue."
Posted Feb 28, 2017 - 14:45 EST
Update
From Amazon: "Increased Error Rates"
"We're continuing to work to remediate the availability issues for Amazon S3 in US-EAST-1. AWS services and customer applications depending on S3 will continue to experience high error rates as we are actively working to remediate the errors in Amazon S3."
Source: http://status.aws.amazon.com/
Posted Feb 28, 2017 - 13:54 EST
Update
S3 is still currently down. We have yet to receive an update from the team at Amazon, but will as soon as we have any information.
Posted Feb 28, 2017 - 13:40 EST
Monitoring
Cached files for our JavaScript library are being served to handle various requests, but you may experience intermittent issues with our application.
Posted Feb 28, 2017 - 13:16 EST
Identified
We are currently experiencing an outage on Amazon S3. Our engineering team is investigating and closely following updates from Amazon. I'll update here in 10 minutes.
Posted Feb 28, 2017 - 13:05 EST